Digital Radio Central - Sponsored by TSS Radio
  DRC Home Page DRC Forums Contact Us  
 
SIRIUS Backstage Forum
 
 
 
  Sirius Satellite Radio XM Satellite Radio iTunes/iPod Slacker Pandora  
 
 
FAQ Members List Calendar Search Today's Posts Mark Forums Read  
Go Back   SIRIUS Backstage Forum > > >
Visit Digital Radio Central

Notices

SIRIUS S50 You asked for it, now you got it! A forum all about the SIRIUS S50.

 
 
Thread Tools Display Modes
 
 
Old 01-28-2006, 11:39 AM   #1
martin27
Channel Surfer
 
Join Date: Nov 25, 2005
Posts: 41
martin27 is on a distinguished road
Default PROBLEM: USB Device Not Recognized

I am trying to upgrade my firmware so I can do a "Reset Channels" which I am told might bring my S50 back to life. (Right now I can only listen to previous recordings. Every time I plug into the car dock I get "Invalid Channel" or a freeze at the dog logo. I have heard no new content for 10 days now. All my Scheduled Recordings have modified themselves to record channel 255, which of course does not exist.)

But when I plug the S50 into my computer it says "USB Device Not Recognized". I tried this as a normal user and also as administrator (reluctantly) but no joy. It does not matter if I power the S50 on first and then plug it in, or vice versa. I also tried "Reset Defaults" with no effect.

I am guessing the S50 USB connection requires some special device driver, that it does not function merely as another disk drive, like a USB memory stick. This surprises me because I have heard that people with non-Micro$haft computers can use the S50 as an additional disk drive without installing the (WinBlows only) My Sirius Studio.

Has anyone plugged their S50 in to a Windows machine without installing My Sirius Studio? Or does direct drive access only work after you install MSS?

Does anyone know a (legal) way to get the Windows S50 device driver without installing My Sirius Studio?

Whenever you run a program someone else wrote, you give that person the ability to do anything you can do with your computer -- delete files, transfer funds from your bank account, anything. When you run someone else's program as administrator you give them the power to totally mess up your whole computer. So before you install anything you have to decide if you trust the authors. Things to consider include: (1) Do they appear to know what they are doing, or do they release code with lots of bugs and insane design features? (2) Have they carefully developed their programs with thoughtful consideration of the users' privacy and security throughout, or did they rush it to market with a screw everybody attitude? (3) Do their behaviors and practices reveal a disciplined approach to software design and update management, or do they have trouble even keeping track of version numbers and telling their customers what was changed and what the known bugs scheduled for future correction are?

Perhaps you can see why I don't want to install My Sirius Studio if there is any other way to get my S50 (sorta) working again.
martin27 is offline  
 
 
Old 01-28-2006, 01:04 PM   #2
lzyby444
Channel Surfer
 
Join Date: Jan 13, 2006
Posts: 16
lzyby444 is on a distinguished road
Default

i had the same problem as u where the mss doesnt recognize the s50. I contacted droobie97 on AIM or aol and he helped me through it and fixed my issue he is a real nice guy too
lzyby444 is offline  
 
 
Old 01-29-2006, 04:15 PM   #3
Morning Wood
Loyal Listener
 
Morning Wood's Avatar
 
Join Date: Nov 11, 2005
Posts: 167
Morning Wood is on a distinguished road
Default

i have this problem too. i've had the unit for about a month and this is the first time it's happening. i'm starting to get a little annoyed.
__________________
Morning Wood is offline  
 
 
Old 02-01-2006, 06:16 PM   #4
ortimer
Just Tuned In
 
Join Date: Nov 27, 2005
Posts: 5
ortimer is on a distinguished road
Default

I've had the unit for months and today was the first time I got the USB DEVICE NOT RECOGNIZED error. For over two hours I unistalled, reinstalled, plugged in, unplugged, took the battery out, put the battery in, restarted, shut down, and even attempted installing the unit on different computers. I tried every conceivable combination and nothing seemed to work. I then called CS and got the standard "we'll call you in 3-5 days with directions on how to do the maybe-it'll-work-maybe-it-wont hard reset."

FINALLY -- I decided to disconnect the unit and started to play a song. I then connected the USB cable while the song was playing and... the S50 was RECOGNIZED!!!

I don't know if this will work for everyone, but dammit, it worked for me.

PS - the magic song was "Angie" by the Rolling Stones.
ortimer is offline  
 
 
Old 02-01-2006, 09:45 PM   #5
cassady
Channel Surfer
 
Join Date: Dec 27, 2005
Posts: 53
cassady is on a distinguished road
Default

had the same problems guys, went through several discussions with sirius and finally advised to send the unit back. Crutchfield sent out a new unit and no problems since
cassady is offline  
 
 
Old 02-04-2006, 07:13 PM   #6
ktm300den
Channel Surfer
 
Join Date: Jan 17, 2006
Location: Mi.
Posts: 50
ktm300den is on a distinguished road
Default

Droobie helped me quite a bit. But my problem was with my computer. I had to remove windows and re-install it. Works fine now.

Den
__________________
Today is a good day for a reality check!!
ktm300den is offline  
 
 
Old 02-10-2006, 05:24 PM   #7
martin27
Channel Surfer
 
Join Date: Nov 25, 2005
Posts: 41
martin27 is on a distinguished road
Default

Just to follow up on this (I'm the original poster) I tried my S50 on four different computers and none of them recognized it. So I cannot upgrade firmware.

I suppose I'm looking at a warranty return, but I'm not ready to take that drastic a step yet. Besides, if I wait a couple months maybe the replacement units will be better... like not fall out of the car dock every time I sneeze.
martin27 is offline  
 
 
Old 02-10-2006, 07:20 PM   #8
Mr. Hanky
Mixologist
 
Join Date: Feb 09, 2006
Posts: 322
Mr. Hanky is on a distinguished road
Default

This does seem strange. I'll go on record to say that I have seen 2 PC's recognize my S50, just by hooking up the USB cable, and no other software installation. I was impressed, and downright shocked when my Mac recognized it, as well. It simply comes up as an external drive over USB. Still can't do much with your S50, if you get it to mount, until you install the MSS software, though. You really should consider taking the dive.

Did your computers have the latest OS service patches?

Oh and also, I have observed the S50 USB connectors can sometimes give intermittent contact. So verify your plugs are seated securely and jiggle the wire a bit, perhaps. You might see your S50 mount and then disappear at random. If so, you know your connections may be flakey.
Mr. Hanky is offline  
 
 
Old 02-10-2006, 09:33 PM   #9
martin27
Channel Surfer
 
Join Date: Nov 25, 2005
Posts: 41
martin27 is on a distinguished road
Default

Quote:
Originally Posted by Mr. Hanky
I'll go on record to say that I have seen 2 PC's recognize my S50, just by hooking up the USB cable, and no other software installation.
Thanks for the reply. That's good to know.

Quote:
Originally Posted by Mr. Hanky
It simply comes up as an external drive over USB. Still can't do much with your S50, if you get it to mount, until you install the MSS software, though.
Well, I've seen other people saying you can copy the firmware update to the correct directory ("folder") on the S50, without MSS. That's all I want to do, update the firmware.

Quote:
Originally Posted by Mr. Hanky
You really should consider taking the dive.
If they ever give us the bookmark ability, so I don't have to write the show date and time on a post-it on my S50 twice a day, I might be motivated to take the chance on MSS. But for the trivial fixes so far, it isn't worth the risk. (Unless my S50 locks up for 10 days again, then the fix wouldn't be so trivial. My original reason for wanting to update firmware was because it would freeze at the dog logo or say "invalid channel" every time I powered up. But after 10 days it magically fixed itself, so now all a firmware update would give me is slightly faster fast-forward, from what I hear.)

Quote:
Originally Posted by Mr. Hanky
Did your computers have the latest OS service patches?
Another good question... I have WinBlows XP with Service Pack 2 and all the latest security patches (over 30... don't get me started...)

Quote:
Originally Posted by Mr. Hanky
Oh and also, I have observed the S50 USB connectors can sometimes give intermittent contact. So verify your plugs are seated securely and jiggle the wire a bit, perhaps. You might see your S50 mount and then disappear at random. If so, you know your connections may be flakey.
I'll try that... but I bet I would have noticed if it showed up briefly on even one of the four computers I tried. Still, another good suggestion. Thanks.
martin27 is offline  
 
 
 

Go Back   SIRIUS Backstage Forum > > >


Digitalradiocentral.com




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:07 PM.
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.39 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All Content Copyright SIRIUS Backstage. All Rights Reserved. SIRIUS and registered trademarks are the property of SIRIUS Satellite Radio, Inc. The opinions posted on SIRIUS Backstage website and forums are those of the individual posters and/or this website and are not necessarily the opinions or positions of SIRIUS Satellite Radio, Inc.